{{indexmenu_n>1}}
====== Modify L3 VPN ======
On this page we demonstrate how we can edit some parameters for an already deployed Service
In this example, we continue with our earlier example of [[guides:user:l3vpn:l3vpn|L3VPN]] and propose to alter its QoS parameters. So Here is the PE's complete configuration
! Cisco_IOS Template 'c7600' Rev=2017-10-23 20:28 Seq=1
! This configuration is automatically generated at 2017-12-01 14:20:33
!
access-list 2 permit 172.16.5.22 0.0.0.0
!
class-map acgroup2
match access-group 2
exit
!
policy-map police
class acgroup2
police 10000 4000 6000 conform-action transmit exceed-action set-qos-transmit 4 violate-action drop
exit
!
ip vrf CustA
rd 172.31.0.11:1
route-target both 65001:1
ip vrf CustB
rd 172.31.0.11:9
route-target both 65001:9
!
interface Ethernet1/2
ip vrf forwarding CustA
ip address 5.5.5.1 255.255.255.252
service-policy input police
no shut
interface Ethernet1/3
ip vrf forwarding CustB
ip address 5.5.5.5 255.255.255.252
service-policy input police
no shut
router bgp 65001
!
address-family ipv4 vrf CustA
redistribute static
redistribute connected
!
address-family ipv4 vrf CustB
redistribute static
redistribute connected
!
Here we can see the QoS' Police parameters are:
police 10000 4000 6000 conform-action transmit exceed-action set-qos-transmit 4 violate-action drop
We can alter these parameters by using Custom Attributes
We create three custom attributes and place them under the node as shown in the snapshot below
{{guides:howto:custom_attributes_01.png?400|}}
Now if we view the Node in BUILD menu, we can see the three custom attributes are shown as below
{{guides:howto:custom_attributes_02.png?400|}}
We can freely alter these custom fields values to as needed.
Lets alter them from 10000,4000 and 6000 to 12000,6000 and 8000 and then generate the config
Now if we head over to Operate --> Tools --> View config, we can see the CLI is automatically updated. (Since the template for Police calls upon these variables)
====== police_qos ======
access-list 2 permit 172.16.5.22 0.0.0.0
!
class-map acgroup2
match access-group 2
exit
!
policy-map police
class acgroup2
police conform-action transmit exceed-action set-qos-transmit 4 violate-action drop
exit
!
Now its matter of creating a specific job to push the config to the device.
For e.g
===== Job Name: =====
Update QoS
==== Commands: ====
{police_qos}
=== Scenario: ===
(the defaults, nothing needs to be modified from the scenario available in the "Default Command Job")
[parameters]
node = 'PE1'
verbose = '-v'
[scenario]
Description Command_job...
task = Command_job
end